Troca do Socket do chip TIA no Atari 2600 Polyvox com Placa Americana Rev. 17

Em 2017 eu fiz uma série de artigos aqui no Skooter Blog mostrando como instalei o mod 2600RGB em meu Atari 2600 da Polyvox com PCB americana, revisão 17.

Mas um probleminha que ocorreu no socket do chip TIA, o mesmo socket onde o 2600RGB se encaixa, ficou pendente desde aquela época. No tira e põe do 2600RGB, cujo encaixe se dá com bastante dificuldade, um dos contatos do socket acabou danificado, como pode ser visto nas fotos:

Esse dano não impedia o console de funcionar, mas de uns bons tempos para cá, percebi que ele estava um tanto sensível, qualquer tapinha na carcaça já fazia a imagem sumir.

Lá no já distante ano de 2019 eu comprei capacitores para meu Super Nintendo e já comprei o socket para o TIA do Atari 2600 (socket de 40 pinos) para fazer essa troca, mas é algo que eu sempre fui deixando para depois. Optei por um socket torneados em vez de estampado, como é o original do Atari 2600, por acreditar que o torneado tenha uma maior durabilidade e que facilitaria o encaixe dos pinos do 2600RGB.

Sockets Torneados de 40 pinos.

Sockets Torneados de 40 pinos.

A troca foi sendo adiada por três motivos: 1) eu nunca havia trocado um socket e temia fazer alguma bobagem e estragar o console; 2) depois do que o Correios fez com o meu Super Nintendo, enviar o console para algum técnico pelo Correios não era uma opção; 3) dois bons técnicos da minha cidade, não especializados em games, mas em quem eu confiaria para esta tarefa, infelizmente faleceram.

No último dia 18/09, um primo trouxe um Atari 2600 que ele adquiriu para testarmos, junto com alguns cartuchos. Como o console dele não funcionou, fomos testar os cartuchos no meu Atari e mais uma vez o defeitinho do socket se manifestou quando eu coloquei o console ligado, que estava no meu colo, de volta no rack.

Decidi então que era chegada a hora de encarar o serviço. Como tinha algum tempinho livre no dia seguinte (domingo, 19/09), resolvi que finalmente faria a troca do socket problemático.

Inicialmente tentei tirar o socket antigo com ar quente, mas não tive sucesso, tenho ainda algum receio com ar quente, pois ele sai derretendo verniz e tudo mais. Temo que essas PCBs de quase 40 anos de idade não aguentem o calor e se estraguem de alguma forma. Talvez seja melhor deixar o ar quente para SMDs e placas mais modernas.

Dessoldar 40 pinos de uma vez só estava além das minhas capacidades, então optei por ir cortando o plástico do socket antigo com um alicate de corte, cuidadosamente, deixando só os contatos metálicos, que eu pude então ir dessoldando um a um da maneira tradicional, com ferro de solda e sugador manual. Um dessoldador/sugador automático já é sonho de consumo há algum tempo, que ainda não se concretizou.

Com o slot antigo removido, soldar o novo foi a parte mais fácil. Eis o resultado:

PCB do Atari 2600 (Rev. 17) com o novo socket do TIA instalado.

PCB do Atari 2600 (Rev. 17) com o novo socket do TIA instalado.

Fui fazer o teste e, para a minha decepção, nada do console funcionar. De volta à bancada improvisada na mesa da sala de jantar, fui testando continuidades entre pinos vizinhos e achei uma continuidade que não deveria existir entre um par de pinos ali na casa dos 30 (não lembro exatamente quais). Era algum resquício mínimo de solda dos pinos que estava fazendo o contato indesejado. Ressoldando os pinos envolvidos o problema se foi e o Atari 2600 voltou a funcionar. Bingo! 🙂

Passei um verniz novo nas novas soldas, terminei a montagem do console, guardei todo o equipamento e achei que o serviço tinha sido executado com sucesso:

Atari 2600 em funcionamento após a troca do socket.

Atari 2600 em funcionamento após a troca do socket.

No dia seguinte (segunda, 20/09) fiz uma live no final da noite testando o console:

Foi aí que eu percebi que as coisas não tinham ido tão bem quanto eu imaginara. Em vários jogos o áudio estava incompleto. Claramente um dos dois canais de áudio do TIA não estava passando o som. Teria eu danificado o TIA? Ou o 2600RGB?

Tentei remover o 2600RGB, conectar o TIA diretamente e ligar o Atari via RF, mas o problema do áudio persistiu. Testei o TIA que veio com o console, aquele com defeito na entrada dos paddles, mas o problema também persistiu. Certamente o problema estava mesmo na placa, danifiquei alguma coisa na troca do socket, mas o que?

Resolvi dar uma olhada no esquema do Atari 2600, disponível no site da Atari Age, e logo percebi que há uma ponte entre os pinos 12 e 13 do TIA, que são os pinos de áudio. Mas na minha placa, esses pinos não estavam dando continuidade. Onde estaria essa ponte na placa? Ou melhor, onde ela deveria estar?

Esquema do Atari 2600, note a ponte entre os pinos 12 e 13 do TIA.

Esquema do Atari 2600, note a ponte entre os pinos 12 e 13 do TIA.

Ponte entre os pinos de áudio do TIA no esquema do Atari 2600.

Ponte entre os pinos de áudio do TIA no esquema do Atari 2600.

Felizmente eu tiro foto de tudo que vou mexer, então acabei encontrando uma foto antiga de quando estava instalando o 2600RGB. Eis que havia uma pequena ponte entre os os pinos 12 e 13 do socket do TIA, e no lado da PCB que fica com as soldas. É minúscula, mas dá para ver um brilhinho do metal ali.

A PCB do meu Atari 2600, em 2017.

A PCB do meu Atari 2600, em 2017.

Ponte entre os pinos de áudio do TIA em foto antiga da PCB do meu Atari 2600.

Ponte entre os pinos de áudio do TIA em foto antiga da PCB do meu Atari 2600.

Essa ponte sumiu no processo de troca de socket, não sei exatamente em que momento, talvez na hora de tirar as soldas velhas ela acabou sugada, talvez foi algum cortezinho apenas na hora de limpar, talvez tenha sido puxada ao cortar o socket com o alicate. Enfim, fiz alguma bobagem e essa ponte sumiu. O jeito foi refazer a ponte unindo os terminais dos pinos 12 e 13 com solda. Fui testar novamente e o problema do som de fato foi resolvido assim! 😀

Mais um pouco de verniz para proteger a nova solda, fechei então o console e na noite da terça (21/09) fiz uma nova live, dessa vez com o áudio perfeito:

E agora meu Atari 2600 está bem mais estável, posso bater na carcaça dele sem que ele trave. Era realmente o socket que estava causando as instabilidades.

Quanto aos benefícios do socket torneado, espero que dure mais, mas encaixar o 2600RGB nele é igualmente complicado. Parece que ele nunca encaixa completamente. Mas encaixei o máximo que consegui, sacudi bastante ele e ele não sai, então acho que está ok.

Poderia ter poupado uma boa dor de cabeça enviando o console para algum técnico? Provavelmente. Mas poderia ter tido uma dor de cabeça maior ainda se tivesse acontecido o mesmo que com o meu Super Nintendo. Então estou satisfeito. Pelo menos aprendi algo novo e pude compartilhar com vocês.

E assim, o meu Atari 2600 com o 2600RGB continua conectado na minha TV da sala, via OSSC, me oferecendo a melhor imagem que eu poderia obter do hardware original. Isso vem bastante a calhar, dado que o núcleo do Atari 2600 no MiSTer é bom mas ainda está longe de ser perfeito.

Compartilhe o artigo com seus amigos se você gostou 😉 . O Skooter Blog precisa de sua ajuda na divulgação para continuar existindo.

0 0 votos
Article Rating

Link permanente para este artigo: https://www.skooterblog.com/2021/10/11/troca-do-socket-do-chip-tia-no-atari-2600-polyvox-com-placa-americana-rev-17/

Inscrever
Notificar sobre
guest
1 Comentário
mais velhos
mais novos mais votados
Inline Feedbacks
Ver todos os comentários

Para evitar a solda ficar dando contato entre dois pontos, eu recomendo usar fluxo de solda, ela praticamente “chupa” a solda para o ponto certo, daí você consegue aplicar uma quantidade bem menor.
Grande sacada tirar as fotos antes de instalar o Mod RGB, eu comecei a fazer isso ultimamente também e ajuda para burro quando você fica em dúvida sobre como estava o circuito originalmente.
Ficou show a qualidade agora.

×
1
0
Gostaríamos de saber o que você pensa, deixe seu comentáriox
()
x